Posts Tagged ‘Intel’

Resolver problemas de audio en debian Wheezy con Intel Corporation NM10/ICH7

11 mayo, 2013

Hace unos días que se liberó Wheezy e instalé la nueva versión, entre uno de los pequeños inconvenientes que tuve fue que me quedaba sin sonido después de reiniciar por primera vez después de instalar el nuevo sistema.

La solución como siempre la encontré buscando por la red posibles soluciones. Dejo aquí el proceso que seguí por si hay alguien más con el mismo problema:

1. Editar «/etc/modprobe.d/alsa-base.conf»

# nano /etc/modprobe.d/alsa-base.conf

al final del documento agregamos la siguiente linea:

options snd_hda_intel model=3stack-6ch-dig

2.  Editamos también el documento /etc/pulse/daemon.conf
# gksu gedit /etc/pulse/daemon.conf

Buscamos la linea  «; default-sample-channels = 2»

Y le quitamos el ; además de cambiar el valor 2 por 6

Debe de quedar así: default-sample-channels = 6

3. Reiniciamos el sistema.

4. Reconfiguramos alsamixer

# alsamixer

Presionamos F6 para elegir nuestra tarjeta de sonido

Captura de pantalla de 2013-05-11 23:57:43

Nos movemos con la flechas de dirección hasta la opción Channel y le cambiamos el valor de 2ch por 6ch.

Captura de pantalla de 2013-05-11 23:59:23

Ya sólo queda ajustar los niveles de  las demás opciones. En mi caso sólo tuve que bajar el nivel de Front Mic un poco para que el sonido quedara con la mejor calidad.

Captura de pantalla de 2013-05-12 00:04:54

Salimos con Esc.

Y ya hay sonido en Wheezy.

 

Configurar tarjeta gráfica Intel Corporation 82945G/GZ Integrated Graphics Controller en Debian.

28 junio, 2009

 

Hace algún tiempo ya que Actualice mi Debian de Etch a Lenny. Cuando lo hice empecé con un problema con la configuración del Servidor X.

Sucedía que de repente aparecía un pantallazo que decía:

«Fallo al iniciar el servidor X (su interfaz gráfico). Parece como si no estuviera configurado correctamente. ¿Quiere ver la salida del servidor X para diagnosticar el problema?»

Al decirle que si daba una salida más detallada del problema.

La única manera de salir de ahí era irse a modo consola y reiniciar el sistema.

La solución que logre encontrar navegando por la web fue la siguiente.

1 – Antes que nada, con synaptic, hay que eliminar los paquetes de xserver-xorg-video-x que no correspondan al Intel.

2 – Instalar el driver para la tarjeta Intel:

# apt-get install xserver-xorg-video-intel

e instalamos algunos paquetes necesarios:

# apt-get install libdrm2 libgl1-mesa-dri libpng3 libpng12-0 libpng12-dev libxdamage1 libxcomposite1 x11proto-core-dev x11proto-composite-dev x11proto-damage-dev x11proto-fixes-dev x11proto-gl-dev x11proto-render-dev x11proto-randr-dev libcairo2 libcairo2-dev libcairo-perl libmono-cairo1.0-cil python-cairo libgl1-mesa-dev mesa-common-dev mesa-utils libsvn1 libglitz1 libglitz-glx1 libxfont1 libfontenc1 libwnck-common libwnck22 libsvn1 libglu1-mesa

3 – Editar el xorg.conf de forma que quede de la siguiente manera:

# nano /etc/X11/xorg.conf

 

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "Module"
Load    "dri"
Load    "glx"
Load    "dbe"
EndSection
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "latam"
EndSection
Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "50"
Option "SHMConfig" "true
EndSection
Section "Device"
Identifier "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Driver "intel"
Option "XAANoOffscreenPixmaps" "true"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "UseFBDev" "true"
Option "AccelMethod" "XAA"
Option "DRI" "true"
Option "FrameBufferCompression" "false"
BusID "PCI:0:2:0"
EndSection
Section "Monitor"
Identifier "Configured Monitor"
EndSection
Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82945G/GZ Integrated Graphics Controller"
Monitor "Generic Monitor"
Option "addARGBGLXVisuals" "True"
DefaultDepth 24
EndSection
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Synaptics Touchpad"
Option "AIGLX" "true"
EndSection
Section "Extensions"
Option "Composite" "enable"
EndSection
Section "DRI"
Group "video"
Mode 0660
EndSection

Guardar y cerrar.

Y listo. 😛

Espero que como me funcionó a mi, le funcione a alguien más porque realmente este problema desespera!.