Posts Tagged ‘hplip’

Instalar HP DESKJET 3050 ALL-IN-ONE j610 SERIES en Debian

30 diciembre, 2011

* Este procedimiento lo he probado tanto en Squeeze como en Wheezy y en ambos va bien.

Hace poco compré una impresora de dicha marca y modelo y me sucedió lo que nunca me había sucedido con impresoras en Debian, tuve problemas para la instalación.

Resulta que el hplip que instala por defecto Squeeze no contiene el controlador de este modelo, por lo que fue necesario descargarlo de la página oficial de hp.

Al instalarlo,  ya podía agregar la impresora con su controlador, pero seguía teniendo problemas. Aunque el sistema me detectaba la impresora, al enviar un trabajo nadamas no lo imprimía.

Buscando por la red, encontré que lo que me solucionó el problema fue lo siguiente:

Antes de instalar el controlador hay que hacer esto:

Como root, hay que ir a /usr/lib/cups/filter, y al archivo foomatic-rip, hay que hacerle una copia cambiendole el nombre (a la copia), por foomatic-rip-hplip, y después, hacerle a éste último un enlace en el directorio /usr/bin

Y entonces sí, instalar el software que hemos descargado: (en el mismo link hay un tutorial detallado para la instalación del software).

Nos dirigimos al directorio en que lo hemos descargado:

# cd Desktop/

E instalamos:

# sh hplip-3.11.10.run

Durante la instalación es necesario para detectar la impresora reiniciar el equipo o desconectar y volver a conectarla. el proceso mismo pregunta cuál opción es preferible, en mi caso elegí  deconectar, que es la opción más sencilla y después de un par de minutos de instalación, ya tenía mi equipo funcionando correctamente, tanto impresora como escaner. 🙂

Escanear con multifuncional HP en Debian Lenny

2 agosto, 2009

Cuando utilizaba Debian Etch nunca tuve problemas con el Escáner, pues al instalar la multifuncional HP funcionaba correctamente tanto la impresora como el escáner.

Con Debian Lenny tuve el problema de que únicamente me funcionaba la impresora, y el Escáner no, así que busque soluciones y lo que me resolvió el problema fue lo siguiente: (Teniendo la multifuncional conectada y encendida)

Hay que tener instalado hplip:

# apt-get install hplip

e instalar también hpoj:

# apt-get install hpoj

y en seguida ejecutamos lo siguiente:

# /etc/init.d/hpoj setup

Y el escáner funciona 😛