Posts Tagged ‘Audio’

Resolver interferencia de Skype con Rhythmbox en Debian

13 noviembre, 2014

Resulta que al instalar Skype en debian y hacerlo funcionar correctamente, aún hay otro problemilla que a mi me apareció. El problema era que cuando estaba escuchando mi música a través de Rhythmbox y se me ocurría abrir skype e iniciar mi sesión, se detenía la reproducción de música y había que dar de nuevo en reproducir para que la canción continuara. Lo mismo sucedía al enviar o recibir un mensaje en el chat y también con cualquier otra notificación del Skype.

Aunque desmarcara la opción que Skype trae en Opciones/Dispositivos de sonido, la cual dice “Permitir que skype ajuste automáticamente mis niveles de mezclado” el problema no se resolvía.

Buscando un poco por la red, encontré lo que me solucionó el problema en el siguiente link: https://wiki.archlinux.org/index.php/Skype#Skype_sounds_stops_media_player_or_other_sound_sources

Las soluciónes son:

1.

# nano /etc/pulse/default.pa

Ahí, buscar la linea “load-module module-role-cork” y comentarla, para que quede así:

# load-module module-role-cork

2.

# nano /etc/pulse/daemon.conf

Buscar la linea “flat-volumes = yes” y cambiarle el valor por “no”. Quedaría así:

flat-volumes = no

3.

En una terminar de usuario correr lo siguiente:

$ pactl unload-module module-role-cork

Para probar cada solución, habrá que reiniciar el sistema.


Resolver problemas de audio en debian Wheezy con Intel Corporation NM10/ICH7

11 mayo, 2013

Hace unos días que se liberó Wheezy e instalé la nueva versión, entre uno de los pequeños inconvenientes que tuve fue que me quedaba sin sonido después de reiniciar por primera vez después de instalar el nuevo sistema.

La solución como siempre la encontré buscando por la red posibles soluciones. Dejo aquí el proceso que seguí por si hay alguien más con el mismo problema:

1. Editar “/etc/modprobe.d/alsa-base.conf”

# nano /etc/modprobe.d/alsa-base.conf

al final del documento agregamos la siguiente linea:

options snd_hda_intel model=3stack-6ch-dig

2.  Editamos también el documento /etc/pulse/daemon.conf
# gksu gedit /etc/pulse/daemon.conf

Buscamos la linea  “; default-sample-channels = 2”

Y le quitamos el ; además de cambiar el valor 2 por 6

Debe de quedar así: default-sample-channels = 6

3. Reiniciamos el sistema.

4. Reconfiguramos alsamixer

# alsamixer

Presionamos F6 para elegir nuestra tarjeta de sonido

Captura de pantalla de 2013-05-11 23:57:43

Nos movemos con la flechas de dirección hasta la opción Channel y le cambiamos el valor de 2ch por 6ch.

Captura de pantalla de 2013-05-11 23:59:23

Ya sólo queda ajustar los niveles de  las demás opciones. En mi caso sólo tuve que bajar el nivel de Front Mic un poco para que el sonido quedara con la mejor calidad.

Captura de pantalla de 2013-05-12 00:04:54

Salimos con Esc.

Y ya hay sonido en Wheezy.